Liferay – Unable to deploy portlet in Liferay Portal

Problem: Unable to deploy portlet in Liferay Portal Server 6.1.0 CE. Während des deploys erhalte ich den Fehler „war does not support this version of Liferay“ oder “ Add war to the blacklist“.

com.liferay.portal.kernel.deploy.auto.AutoDeployException: sample-struts-portlet-6.1.0.1.war does not support this version of Liferay
 at com.liferay.portal.deploy.auto.PortletAutoDeployer.autoDeploy(PortletAutoDeployer.java:99)
 at com.liferay.portal.deploy.auto.PortletAutoDeployListener.deploy(PortletAutoDeployListener.java:78)
 at com.liferay.portal.kernel.deploy.auto.AutoDeployDir.processFile(AutoDeployDir.java:180)
 at com.liferay.portal.kernel.deploy.auto.AutoDeployDir.scanDirectory(AutoDeployDir.java:222)
 at com.liferay.portal.kernel.deploy.auto.AutoDeployScanner.run(AutoDeployScanner.java:50)
Caused by: com.liferay.portal.kernel.deploy.auto.AutoDeployException: sample-struts-portlet-6.1.0.1.war does not support this version of Liferay
 at com.liferay.portal.tools.deploy.BaseDeployer.deployFile(BaseDeployer.java:746)
 at com.liferay.portal.deploy.auto.PortletAutoDeployer.autoDeploy(PortletAutoDeployer.java:96)
 ... 4 more
06:08:32,312 INFO  [AutoDeployDir:203] Add sample-struts-portlet-6.1.0.1.war to the blacklist 

Mein Problem hierbei war nicht das erstellen des Portlets in einer höheren Version oder einer niedrigeren. Es war lediglich ein Eintrag in einer XML File der gefehlt hat.

Lösung:
Bearbeitet die Datei: „docroot\WEB-INF\liferay-plugin-package.properties“ und fügt folgenden Parameter ein bzw. verändert die Version dementsprechend.

liferay-versions=6.1.0

Jetzt müsst ihr den Server neustarten um das Portlet von der Blacklist zu bekommen. Anschließend sollte es wieder deployed werden können. Wenn das nicht der Fall ist, schaut bitte noch in der anderen File nach: „liferay-plugin-package.xml“

<liferay-versions>
        <liferay-version>6.1.0+</liferay-version>
    </liferay-versions>

Schreibe einen Kommentar

Deine E-Mail-Adresse wird nicht veröffentlicht. Erforderliche Felder sind mit * markiert.